January 30th, 2021

AngrySnarl

Программистское: LetsEncrypt

*Мечтательно*
Вот работал-бы let's encrypt не через жопу, как было-бы здорово.
Хочу вот поставить. Но моя 16.04 убунта виртуальная _не может_. Потому что вместо нормальной дистрибуции certBot есть только "snap". Для чего надо поставить snapd и сервис. Ну ок, ставлю. Всё вроде ок. Но не работает потому что
error: cannot install "certbot": Post https://api.snapcraft.io/v2/snaps/refresh: x509: certificate
signed by unknown authority

Как затрахал этот цирк с сертификатами... Ну дайте блядь мне поставить ваш сраный сертификат и всё. Но нет, туманные "Ну вы почините типа ваши сертификаты" и "ну дайте нашему сервису правильный доступ к сертификатам и всё заработает". ГДЕ, где этот доступ. Какой из 100500 сертификатов "правильный". При этом сами уроды пишут что "ну вот в этой версии 16.04 убунты всё уже установлено так что фиг вам а не инструкции". Нет, не поставлено и не работает и инструкций нет.

Ненавижу эту идиотскую систему. И эти блядские роботы которых надо тыкать везде, чтобы оно сертификат раз в месяц обновляло.